хуй

antipodarok


Антиподарок

аренда подъемников


Previous Entry Share Next Entry
1C Работа с Интернет
хуй
antipodarok

Работа с электронной почтой

Как организовать работу с электронной почтой через установленного почтового клиента?

Почта = Новый Почта;
Почта.Подключиться("login", "password"); 

Сообщ = Новый ПочтовоеСообщение;
Сообщ.Текст = "Доброе время суток!!!!";
Сообщ.Тема = "Срочно в номер!!!"; 

Данные = Новый ДвоичныеДанные("c:\attach.txt"); 

Сообщ.Вложения.Добавить(Данные,"attach.txt");
Сообщ.Получатели.Добавить("hline@1c.ru"); 

Почта.Послать(Сообщ, Ложь);
Почта.Отключиться(); 

Почта = Новый Почта;
Почта.Подключиться("login", "password"); 

Выборка = Почта.Выбрать(Истина, Ложь);
Для Каждого Сообщение Из Выборка Цикл
	Сообщить("Тема: " + Строка(Сообщение.Тема));
	Сообщить("Текст: " + Строка(Сообщение.Текст)); 

	Для Каждого Вложение Из Сообщение.Вложения Цикл
		Сообщить(Строка(Вложение.Наименование));
	КонецЦикла;
КонецЦикла;

Как организовать работу с почтой без установленного почтового клиента на компьютере пользователя?

// Сформировать почтовый профиль.
// При отправке нет необходимости указывать настройки, связанные с POP сервером.
ИПП = Новый ИнтернетПочтовыйПрофиль;
ИПП.АдресСервераSMTP = Константы.АдресСервераSMTP.Получить();
ИПП.ВремяОжидания = Константы.ВремяОжидания.Получить();
ИПП.Пароль = Константы.Пароль.Получить();
ИПП.ПарольSMTP = Константы.ПарольSMTP.Получить();
ИПП.Пользователь = Константы.Пользователь.Получить();
ИПП.ПользовательSMTP = Константы.ПользовательSMTP.Получить();
ИПП.ПортSMTP = Константы.ПортSMTP.Получить(); 

// Создать сообщение.
Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Получатели.Добавить("hline@1c.ru");
Сообщение.Отправитель.Адрес = "booktest@yandexyandex.ru";
Сообщение.Тема = "Срочно в номер!";
Сообщение.Тексты.Добавить("Доброе время суток!"); 

Вложение = Новый ДвоичныеДанные(ПутьКФайлуВложения); 

Сообщение.Вложения.Добавить(Вложение,"attach.txt"); 

// Подключиться и отправить.
Почта = Новый ИнтернетПочта;
Почта.Подключиться(Профиль);
Почта.Послать(Сообщение);
Почта.Отключиться(); 

// Формирование почтового профиля.
// При получении нет необходимости указывать настройки, связанные с SMTP сервером.
СостояниеПриема = "Подключение к серверу";
ИПП = Новый ИнтернетПочтовыйПрофиль;
ИПП.АдресСервераPOP3 = Константы.АдресСервераPOP3.Получить();
ИПП.ВремяОжидания = Константы.ВремяОжидания.Получить();
ИПП.Пароль = Константы.Пароль.Получить();
ИПП.Пользователь = Константы.Пользователь.Получить();
ИПП.ПортPOP3 = Константы.ПортPOP3.Получить(); 

Соединение = Новый ИнтернетПочта;
Соединение.Подключиться(ИПП);
СостояниеПриема = "Получение выборки писем";
Выборка = Соединение.Выбрать(ЗабиратьССервера);
СостояниеПриема = "Создание документов - писем";
КоличествоВВыборке = Выборка.Количество();
Индекс = 1; 

Для Каждого Письмо Из Выборка Цикл
	ТекПозиция = Окр(Индекс*100/КоличествоВВыборке);
	Если ТекПозиция <> Позиция Тогда
		Позиция = ТекПозиция;
	КонецЕсли; 

	Док = Документы.Письмо.СоздатьДокумент();
	Док.Тема = Письмо.Тема;
	СтрПолучатели = ""; 

	Для Каждого Адрес Из Письмо.Получатели Цикл
		СтрПолучатели = СтрПолучатели + Адрес.Адрес + ",";
	КонецЦикла; 

	Док.Получатели = СтрПолучатели;
	Если ТипЗнч(Письмо.Отправитель) = Тип("Строка") Тогда
		Отправитель = Письмо.Отправитель;
	Иначе
		Отправитель = Письмо.Отправитель.Адрес;
	КонецЕсли; 

	Док.Отправитель = Отправитель;
	Содержание = ""; 

	Для Каждого ТекстСообщения Из Письмо.Тексты Цикл
		Содержание = Содержание + ТекстСообщения.Текст + Символы.ПС;
	КонецЦикла; 

	Док.Содержание = Содержание; 

	Индекс = Индекс + 1; 

	Док.Записать();
КонецЦикла; 

Соединение.Отключиться();

Работа с файлами

Загрузка файлов по FTP

Процедура ЗагрузитьОтмеченные(Кнопка) 

	Сервер = Новый FTPСоединение(FTPServer); 

	Для Каждого Файл Из ПолеСписка Цикл
		Если Файл.Пометка Тогда
			Сервер.Получить(Файл.Значение.ПолноеИмя, "с:\temp" +
                                                   Файл.Значение.ПолноеИмя);
			Файл.Пометка = Ложь;
		КонецЕсли;
	КонецЦикла; 

КонецПроцедуры 

Процедура Просмотреть(Кнопка)

	Сервер = Новый FTPСоединение(FTPServer);
	МассивФайлов = Сервер.НайтиФайлы("/","*.*"); 

	Для Каждого Файл Из МассивФайлов Цикл
		Если Файл.ЭтоФайл() Тогда
			ПолеСписка.Добавить(Файл, Файл.Имя)
		КонецЕсли;
	КонецЦикла; 

КонецПроцедуры

Выполнение HTTP запроса

СерверИсточник = HTTPserver;
Адрес = "/price.asp";
ИмяВходящегоФайла = "c:\temp\input.html";
НТТР = Новый HTTPСоединение(СерверИсточник);
НТТР.Получить(Адрес, ИмяВходящегоФайла);
ВходящийФайл = Новый Файл(ИмяВходящегоФайла);

Как установить HTTP соединение если подключение через прокси (proxy) сервер

// Укажем настройки прокси-сервера
ПроксиСервер = Новый ИнтернетПрокси;
ПроксиСервер.Пользователь = "Кинев";
ПроксиСервер.Пароль = "12345";
ПроксиСервер.Установить("http", "10.1.1.223", "3100");

СерверИсточник = "www.cennic-etiketka.com";
Адрес = "/price.asp";
ИмяВходящегоФайла = "c:\temp\input.html";
// Укажем в HTTP соединении что у нас есть проксик
НТТР = Новый HTTPСоединение(СерверИсточник,,,, ПроксиСервер);
НТТР.Получить(Адрес, ИмяВходящегоФайла);
ВходящийФайл = Новый Файл(ИмяВходящегоФайла);
Tags: ,

?

Log in